level 1
追光的少年哟
楼主
我使用fedora23安装samba,服务起不来。重装也不行。
报错如下:
# systemctl status smb.service -l
â— smb.service - Samba SMB Daemon
Loaded: loaded (/usr/lib/systemd/system/smb.service; disabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Wed 2016-05-18 16:20:07 CST; 1min 8s ago
Process: 3572 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=exited, status=127)
Main PID: 3572 (code=exited, status=127)
May 18 16:20:07 localhost.localdomain systemd[1]: Starting Samba SMB Daemon...
May 18 16:20:07 localhost.localdomain smbd[3572]: /usr/sbin/smbd: relocation error: /lib64/libsamba-credentials.so.0: symbol GSS_KRB5_CRED_NO_CI_FLAGS_X, version gssapi_krb5_2_MIT not defined in file libgssapi_krb5.so.2 with link time reference
May 18 16:20:07 localhost.localdomain systemd[1]: smb.service: Main process exited, code=exited, status=127/n/a
May 18 16:20:07 localhost.localdomain systemd[1]: Failed to start Samba SMB Daemon.
May 18 16:20:07 localhost.localdomain systemd[1]: smb.service: Unit entered failed state.
May 18 16:20:07 localhost.localdomain systemd[1]: smb.service: Failed with result 'exit-code'.
看起来好像是库的问题,怎么破。
2016年05月18日 08点05分
1
报错如下:
# systemctl status smb.service -l
â— smb.service - Samba SMB Daemon
Loaded: loaded (/usr/lib/systemd/system/smb.service; disabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Wed 2016-05-18 16:20:07 CST; 1min 8s ago
Process: 3572 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=exited, status=127)
Main PID: 3572 (code=exited, status=127)
May 18 16:20:07 localhost.localdomain systemd[1]: Starting Samba SMB Daemon...
May 18 16:20:07 localhost.localdomain smbd[3572]: /usr/sbin/smbd: relocation error: /lib64/libsamba-credentials.so.0: symbol GSS_KRB5_CRED_NO_CI_FLAGS_X, version gssapi_krb5_2_MIT not defined in file libgssapi_krb5.so.2 with link time reference
May 18 16:20:07 localhost.localdomain systemd[1]: smb.service: Main process exited, code=exited, status=127/n/a
May 18 16:20:07 localhost.localdomain systemd[1]: Failed to start Samba SMB Daemon.
May 18 16:20:07 localhost.localdomain systemd[1]: smb.service: Unit entered failed state.
May 18 16:20:07 localhost.localdomain systemd[1]: smb.service: Failed with result 'exit-code'.
看起来好像是库的问题,怎么破。